Outgoing call issues

Incident Report for JHE IT

Resolved

We are happy this is resolved.
Posted Jul 20, 2026 - 11:00 UTC

Monitoring

A fix has been applied and outgoing calls are working again.
Posted Jul 20, 2026 - 10:43 UTC

Identified

We are aware of issues with outgoing calls and our upstream supplier is looking into it as priority.
Posted Jul 20, 2026 - 10:33 UTC
This incident affected: Cloud Voice (Phone System).